summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-11-04 16:06:56 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-11-04 16:27:50 +0100
commitd13559e540b058e7d74cc20dcdb0e248501531d0 (patch)
treefa5d5360512ca267fc2551d04b26db1c57752678 /CMakeLists.txt
parent8779bda49a91ece85e777aea1e6c5519b62ef66b (diff)
downloadtdmtheme-d13559e540b058e7d74cc20dcdb0e248501531d0.tar.gz
tdmtheme-d13559e540b058e7d74cc20dcdb0e248501531d0.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9d936b9bb49200e398438118d93dd04111a4c840)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 894f032..cb989be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,7 +56,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )