summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-10 22:23:56 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-10 22:24:14 +0100
commit21419a4c58e82acc9c6039c6546d1fe068529eb0 (patch)
treeebb22fe4d021e11ea2c5cf7b44721eec530e76dd /po/CMakeLists.txt
parent97208d6dbb3b1c4dd4ed77e5d282e408dbeb85bd (diff)
downloadtdmtheme-21419a4c58e82acc9c6039c6546d1fe068529eb0.tar.gz
tdmtheme-21419a4c58e82acc9c6039c6546d1fe068529eb0.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a037fdbd50cfe5a0aaeae5d9c498dbaae9f9c930)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..46fba83
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,6 @@
+# build translations if some are already available
+
+file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+if( _srcs )
+ tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+endif( )