summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 13:45:34 +0200
commit5f344470718aafe87173d37c3bf4e1ce18fc0547 (patch)
tree1954d72c2773178204e2ce975837662ace8874c9 /translations/messages/CMakeLists.txt
parent6f630a485b5575044a6b1e94fa10de4bac19800b (diff)
downloadtdmtheme-5f344470718aafe87173d37c3bf4e1ce18fc0547.tar.gz
tdmtheme-5f344470718aafe87173d37c3bf4e1ce18fc0547.zip
Use common rules for build and install documentation and translations.r14.0.11
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 11b03c94ac7752c78a0844ec594bf791d783a732)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/translations/messages/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )