summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-10-20 14:40:51 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-01-15 15:15:39 +0100
commit7fefe15989a08e255ade5e577c781701b157d430 (patch)
tree094796ae879ca732f013f7ff6baf059da9d3b862 /CMakeLists.txt
parentade9896cdea394b76db639c1f22a43821a9d1ecd (diff)
downloadtork-7fefe15989a08e255ade5e577c781701b157d430.tar.gz
tork-7fefe15989a08e255ade5e577c781701b157d430.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 81b64bcfc0a32fdeb0e4f367adbf273d924e55f4)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt94
1 files changed, 94 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..e87a31a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,94 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+#### general package setup
+
+project( tork )
+set( VERSION R14.1.0 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckIncludeFileCXX )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_FAILSAFE "Enable failsafe support" ${WITH_ALL_OPTIONS} )
+option( WITH_GNUTLS "Enable GnuTLS support" OFF )
+option( WITH_EMBEDDED_GEOIP "Enable support with embedded GeoIP-1.4 library" OFF )
+option( WITH_LIVECD_SUPPORT "Disable features unsuitable for LiveCD use" OFF )
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_KONQPLUGIN "Build konqplugin" ${BUILD_ALL} )
+option( BUILD_TORAPPLET "Build torkapplet" ${BUILD_ALL} )
+option( BUILD_TOR_IOSLAVE "Build tor_ioslave" ${BUILD_ALL} )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )
+
+
+##### other data
+
+install(
+ FILES tips
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
+)
+