summaryrefslogtreecommitdiffstats
path: root/examples/customlayout/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-03-15 15:32:40 +0100
committerSlávek Banko <slavek.banko@axis.cz>2024-03-02 18:52:12 +0100
commit12bd9b6b2bba50da9c3444dfb42b985ed2a6a7c1 (patch)
tree8319b9e98b3fa1f2a2a61d7719eb9a714c7ad66a /examples/customlayout/CMakeLists.txt
parent34587584ab80fd696cc9d73dda1326f175125ddf (diff)
downloadtqt3-feat/cmakeConv.tar.gz
tqt3-feat/cmakeConv.zip
Conversion to the cmake building system.feat/cmakeConv
Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'examples/customlayout/CMakeLists.txt')
-rw-r--r--examples/customlayout/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/customlayout/CMakeLists.txt b/examples/customlayout/CMakeLists.txt
new file mode 100644
index 00000000..acff454e
--- /dev/null
+++ b/examples/customlayout/CMakeLists.txt
@@ -0,0 +1,22 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/include
+)
+
+link_directories()
+
+
+##### customlayout (executable)
+
+tde_add_executable( customlayout
+
+ SOURCES
+ border.cpp
+ card.cpp
+ flow.cpp
+ main.cpp
+ LINK
+ tqt-mt-shared
+)
+
+tqt_automoc( customlayout )