summaryrefslogtreecommitdiffstats
path: root/tools/designer/uic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/designer/uic/CMakeLists.txt')
-rw-r--r--tools/designer/uic/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/tools/designer/uic/CMakeLists.txt b/tools/designer/uic/CMakeLists.txt
new file mode 100644
index 00000000..c4580808
--- /dev/null
+++ b/tools/designer/uic/CMakeLists.txt
@@ -0,0 +1,41 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../shared
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+link_directories()
+
+
+##### tquic (executable)
+
+set( target tquic )
+
+tde_add_executable( ${target}
+ SOURCES
+ main.cpp uic.cpp form.cpp object.cpp
+ subclassing.cpp embed.cpp
+ ../shared/widgetdatabase.cpp
+ ../shared/domtool.cpp
+ ../shared/parser.cpp
+
+ LINK
+ tqt-mt-shared
+
+ DESTINATION
+ ${BIN_INSTALL_DIR}
+)
+
+set_property(
+ TARGET ${target}
+ APPEND PROPERTY COMPILE_DEFINITIONS
+ QT_INTERNAL_XML
+ UIC
+)
+
+tqt_automoc( ${target} )