summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:31:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:31:07 +0200
commit65d3fb557cc78ad81fc1e411f8f37038fbc0b89e (patch)
tree8487ea4d920a4ef685dd25ce3191e4f2d039c3fd /CMakeLists.txt
parent81178688756b095a5f958cf0b68bfaff31a02e29 (diff)
downloadyakuake-65d3fb557cc78ad81fc1e411f8f37038fbc0b89e.tar.gz
yakuake-65d3fb557cc78ad81fc1e411f8f37038fbc0b89e.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce74127..4c82ef3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,10 +68,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( yakuake )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files