summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9bae1df..50880e2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@ EXTRA_DIST = \
test-widgets.glade
noinst_PROGRAMS = \
- test-widgets
+ test-widgets \
+ test-painter
test_widgets_CFLAGS = \
-I$(top_srcdir) \
@@ -14,4 +15,16 @@ test_widgets_LDADD = \
test_widgets_LDFLAGS = \
$(TDEGTK_LDFLAGS)
+test_painter_SOURCES = test-painter.cpp
+
+test_painter_CXXFLAGS = \
+ -I$(top_srcdir) \
+ $(TDEGTK_CFLAGS)
+
+test_painter_LDADD = \
+ $(TDEGTK_LIBADD)
+
+test_painter_LDFLAGS = \
+ $(TDEGTK_LDFLAGS)
+
# FIXME(Cimi): Figure out what tests must be compiled and add them here.