summaryrefslogtreecommitdiffstats
path: root/plugins/encoder/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-24 05:42:03 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-12 17:44:03 +0100
commit49c75bd470722fedbee23120cf5f4206c744debd (patch)
tree338d0510532fec3aa9fce31b4139718a97bb096e /plugins/encoder/CMakeLists.txt
parent55ee5f6cfcf18a9a558f338c425c8f7655335a2d (diff)
downloadk3b-49c75bd470722fedbee23120cf5f4206c744debd.tar.gz
k3b-49c75bd470722fedbee23120cf5f4206c744debd.zip
Initial cmake conversion
(cherry picked from commit 737e53d58ce8cafd6f3835dc93721851476bad1c)
Diffstat (limited to 'plugins/encoder/CMakeLists.txt')
-rw-r--r--plugins/encoder/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/plugins/encoder/CMakeLists.txt b/plugins/encoder/CMakeLists.txt
new file mode 100644
index 0000000..8a2c500
--- /dev/null
+++ b/plugins/encoder/CMakeLists.txt
@@ -0,0 +1,16 @@
+#################################################
+#
+# (C) 2016 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+
+add_subdirectory( sox )
+add_subdirectory( external )
+tde_conditional_add_subdirectory( WITH_LAME lame )
+tde_conditional_add_subdirectory( WITH_VORBIS ogg )