summaryrefslogtreecommitdiffstats
path: root/libk3b/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libk3b/scripts/Makefile.am')
-rw-r--r--libk3b/scripts/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/libk3b/scripts/Makefile.am b/libk3b/scripts/Makefile.am
new file mode 100644
index 0000000..6318b9b
--- /dev/null
+++ b/libk3b/scripts/Makefile.am
@@ -0,0 +1,11 @@
+bin_SCRIPTS = k3b_automount
+
+# k3b_automount needs to be installed setuid root
+install-exec-hook:
+ @(chown 0 $(DESTDIR)$(bindir)/k3b_automount && chmod 4755 $(DESTDIR)$(bindir)/k3b_automount) || echo "Please make k3b_automount setuid root" >&2
+ @echo ""
+ @echo "k3b_automount is by default installed with a set SETUID root bit!"
+ @echo "This is needed for K3b to be able to temporarily disable automounting via"
+ @echo "subfs or supermount while burning."
+ @echo ""
+