summaryrefslogtreecommitdiffstats
path: root/plugins/decoder/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/decoder/Makefile.am')
-rw-r--r--plugins/decoder/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/plugins/decoder/Makefile.am b/plugins/decoder/Makefile.am
new file mode 100644
index 0000000..1b4eafa
--- /dev/null
+++ b/plugins/decoder/Makefile.am
@@ -0,0 +1,26 @@
+
+if include_OGG
+DECOGGDIR = ogg
+endif
+
+if include_MP3
+DECMP3DIR = mp3
+endif
+
+if include_FLAC
+DECFLACDIR = flac
+endif
+
+if include_AIFF
+DECAIFFDIR = libsndfile
+endif
+
+if include_FFMPEG
+FFMPEGDIR = ffmpeg
+endif
+
+if include_MPC
+MPCDIR = musepack
+endif
+
+SUBDIRS = wave $(DECOGGDIR) $(DECMP3DIR) $(DECFLACDIR) $(DECAIFFDIR) $(FFMPEGDIR) $(MPCDIR)