summaryrefslogtreecommitdiffstats
path: root/plugins/decoder/musepack/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/decoder/musepack/Makefile.am')
-rw-r--r--plugins/decoder/musepack/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/plugins/decoder/musepack/Makefile.am b/plugins/decoder/musepack/Makefile.am
new file mode 100644
index 0000000..beb7d63
--- /dev/null
+++ b/plugins/decoder/musepack/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = -I$(srcdir)/../../../libk3b/plugin \
+ -I$(srcdir)/../../../libk3b/core \
+ -I$(srcdir)/../../../libk3bdevice \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = libk3bmpcdecoder.la
+
+libk3bmpcdecoder_la_SOURCES = k3bmpcdecoder.cpp k3bmpcwrapper.cpp
+
+libk3bmpcdecoder_la_LIBADD = ../../../libk3b/libk3b.la $(MPC_LIBS)
+libk3bmpcdecoder_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+pluginsdir = $(kde_datadir)/k3b/plugins
+plugins_DATA = k3bmpcdecoder.plugin
+
+METASOURCES = AUTO