summaryrefslogtreecommitdiffstats
path: root/plugins/encoder/lame/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/encoder/lame/Makefile.am')
-rw-r--r--plugins/encoder/lame/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/encoder/lame/Makefile.am b/plugins/encoder/lame/Makefile.am
new file mode 100644
index 0000000..4a4d61e
--- /dev/null
+++ b/plugins/encoder/lame/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -I$(srcdir)/../../../libk3b/core -I$(srcdir)/../../../libk3b/plugin -I$(srcdir)/../../../libk3b/core -I$(srcdir)/../../../libk3bdevice $(all_includes)
+
+kde_module_LTLIBRARIES = libk3blameencoder.la
+
+libk3blameencoder_la_SOURCES = base_k3blameencodersettingswidget.ui \
+ base_k3bmanualbitratesettingswidget.ui \
+ k3blameencoder.cpp
+
+libk3blameencoder_la_LIBADD = ../../../libk3b/libk3b.la $(LIB_KDECORE) -lmp3lame
+libk3blameencoder_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+pluginsdir = $(kde_datadir)/k3b/plugins
+plugins_DATA = k3blameencoder.plugin
+
+METASOURCES = AUTO