summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-22 11:21:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-22 11:21:34 +0200
commit3b4b5a1fad7ffa13a3c41162eadb51b01915014d (patch)
tree118e47ce9453baebd57c841722b883183a9f3dcb /CMakeLists.txt
parent259fd92de7328e381b675c17ae807e5199080663 (diff)
downloadkbiff-3b4b5a1fad7ffa13a3c41162eadb51b01915014d.tar.gz
kbiff-3b4b5a1fad7ffa13a3c41162eadb51b01915014d.zip
Use common rules for build and install documentation and translations.
Simplify the structure of the documentation directories. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7986e71..444191f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,10 +76,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files