summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-29 09:31:20 +0200
committergregory guy <gregory-tde@laposte.net>2020-09-29 09:31:20 +0200
commit65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7 (patch)
treed16720590ea865b858be0c6a04e7e0918beaa4ea /CMakeLists.txt
parent66d9fc4d1381b024cca425f30e297662a5d70cf2 (diff)
downloadkerberostray-65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7.tar.gz
kerberostray-65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder doc. Delete empty files NEWS and TODO. Add a README file. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2035eb8..3ac71d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )