summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 16:23:35 +0200
committergregory guy <gregory-tde@laposte.net>2020-10-11 13:12:40 +0200
commitcf1333ecb3899315c395f307ac66c6f12ce82de6 (patch)
tree28384441987808c8b2c5e9e3bd938775543a9571 /CMakeLists.txt
parent774fc9c3fab286c8040bdd37f088f628769c2694 (diff)
downloadklcddimmer-cf1333ecb3899315c395f307ac66c6f12ce82de6.tar.gz
klcddimmer-cf1333ecb3899315c395f307ac66c6f12ce82de6.zip
Drop automake build support.
Add basic cmake build instructions. Deleted empty files ChangeLog and TODO. Rework of the README and NEWS files. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b972bc3..7f81c26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks