summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2019-11-01 11:46:21 +0100
committergregory guy <gregory-tde@laposte.net>2019-11-01 11:46:21 +0100
commit873d0e4138a1569d2a8dfa061d0338b6d017dd3b (patch)
tree330519cff76d1948c74f7674793cdc1399fee3d6 /CMakeLists.txt
parent620d83c4efc5ffcbf89d941410dbddda4daff279 (diff)
downloadknights-873d0e4138a1569d2a8dfa061d0338b6d017dd3b.tar.gz
knights-873d0e4138a1569d2a8dfa061d0338b6d017dd3b.zip
Drop automake build support.
Add basic cmake build instructions in the INSTALL file. Rework of README file and the help page. The History file has been removed, the content added to the ChangeLog file. The file CreatingThemes has moved in the doc folder. Cosmetic changes in CMakeLists.txt . Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c4167a..998efc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,16 +41,16 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
-option( BUILD_EXTRA_THEME "Build extra-theme" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_EXTRA_THEME "Build extra-theme" ${BUILD_ALL} )
##### configure checks
@@ -69,11 +69,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
-add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( media )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
-tde_conditional_add_subdirectory( BUILD_EXTRA_THEME extra-theme )
+add_subdirectory( ${PROJECT_NAME} )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_EXTRA_THEME extra-theme )
##### write configure files