summaryrefslogtreecommitdiffstats
path: root/kplayer/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-11-11 10:25:54 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-11-11 10:25:54 +0100
commit27bcbef791e77e55af73c4f1ec99e0459e3dd213 (patch)
treeb9a7a172617ae6fca14a7717891736974ab06519 /kplayer/CMakeLists.txt
parent90f63a97bb8775f2cc64cb2d6d1c19e65647a138 (diff)
downloadkplayer-27bcbef791e77e55af73c4f1ec99e0459e3dd213.tar.gz
kplayer-27bcbef791e77e55af73c4f1ec99e0459e3dd213.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Use common rules for build and install documentation. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kplayer/CMakeLists.txt')
-rw-r--r--kplayer/CMakeLists.txt23
1 files changed, 11 insertions, 12 deletions
diff --git a/kplayer/CMakeLists.txt b/kplayer/CMakeLists.txt
index 1e4dc4f..5c25179 100644
--- a/kplayer/CMakeLists.txt
+++ b/kplayer/CMakeLists.txt
@@ -107,23 +107,22 @@ tde_install_icons( ${PROJECT_NAME} )
##### other data
-install(
- FILES
- kplayer-play-queue.desktop kplayer-next.desktop
- kplayer-directory.desktop kplayer-actions.desktop
-
- DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+tde_create_translated_desktop(
+ SOURCE
+ kplayer-play-queue.desktop
+ kplayer-next.desktop
+ kplayer-directory.desktop
+ kplayer-actions.desktop
+
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
)
-install(
- FILES kplayerpart.desktop
+tde_create_translated_desktop(
+ SOURCE kplayerpart.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
)
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
install(
FILES input.conf kplayerui.rc kplayerpartui.rc