summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:43 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:14:03 +0900
commite0489f275647b2d9c44a459a8665d9cd6998d9c7 (patch)
tree4e8d5a56ac0db3b1d61ef650f95613f897122c51 /CMakeLists.txt
parent4d81ad9786b8e24e2fcc7ebf7c2ed2f33519f416 (diff)
downloadktechlab-e0489f275647b2d9c44a459a8665d9cd6998d9c7.tar.gz
ktechlab-e0489f275647b2d9c44a459a8665d9cd6998d9c7.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca1cecb..0585edc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )