summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8e0d9ba..7792976 100644
--- a/configure.in
+++ b/configure.in
@@ -131,6 +131,18 @@ AC_TRY_COMPILE(
AC_MSG_RESULT( no )
)
+AC_MSG_CHECKING([for gpsim 0.27.0 availability])
+AC_TRY_COMPILE(
+ [
+#include <gpsim/pic-processor.h>
+void func() { pic_processor *Processor; sizeof(Processor->Wreg); }
+ ],
+ [],
+ AC_MSG_RESULT( yes )
+ have_gpsim_0_27_0=yes,
+ AC_MSG_RESULT( no )
+)
+
CXXFLAGS="$ktechlab_save_CXXFLAGS"
AC_LANG_RESTORE
@@ -199,6 +211,10 @@ if test x$have_gpsim_0_21_4 == xyes || test x$have_gpsim_0_21_11 == xyes || test
LIBS="$ac_save_LIBS"
fi
+if test x$have_gpsim_0_27_0 == xyes; then
+ AC_DEFINE([GPSIM_0_27_0],[],[Gpsim 0.27.0 was found])
+fi
+
AC_SUBST(LIB_GPSIM)
##############################