summaryrefslogtreecommitdiffstats
path: root/microbe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'microbe/CMakeLists.txt')
-rw-r--r--microbe/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/microbe/CMakeLists.txt b/microbe/CMakeLists.txt
new file mode 100644
index 0000000..4e8883a
--- /dev/null
+++ b/microbe/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### microbe (executable)
+
+tde_add_executable( microbe AUTOMOC
+
+ SOURCES
+ btreebase.cpp btreenode.cpp main.cpp
+ traverser.cpp expression.cpp pic14.cpp
+ variable.cpp optimizer.cpp instruction.cpp
+ microbe.cpp parser.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)