summaryrefslogtreecommitdiffstats
path: root/plugins/zeroconf/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
commit9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0 (patch)
treed088b5210e77d9fa91d954d8550e00e372b47378 /plugins/zeroconf/Makefile.am
downloadktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.tar.gz
ktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.zip
Updated to final KDE3 ktorrent release (2.2.6)
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/ktorrent@1077377 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'plugins/zeroconf/Makefile.am')
-rw-r--r--plugins/zeroconf/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/plugins/zeroconf/Makefile.am b/plugins/zeroconf/Makefile.am
new file mode 100644
index 0000000..c6870e6
--- /dev/null
+++ b/plugins/zeroconf/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(top_builddir)/libktorrent -I$(top_builddir)/ktorrent/libktorrent \
+ -I$(srcdir)/../../libktorrent $(all_includes)
+
+METASOURCES = AUTO
+
+if COMPILE_ZEROCONF
+kde_module_LTLIBRARIES = ktzeroconfplugin.la
+endif
+
+ktzeroconfplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) $(AVAHI_LIBS) $(AVAHI_QT3_LIBS)
+ktzeroconfplugin_la_SOURCES = localbrowser.cpp avahiservice.cpp \
+ zeroconfplugin.cpp
+
+ktzeroconfplugin_la_LIBADD = $(LIB_KDECORE) $(LIB_KFILE) $(LIB_KPARTS) $(LIB_KDEUI)\
+ $(LIB_QT) ../../libktorrent/libktorrent.la
+
+noinst_HEADERS = zeroconfplugin.h
+
+kde_services_DATA = ktzeroconfplugin.desktop
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)
+
+