summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-09 15:19:44 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-09 15:19:44 +0200
commit25fe483e16bfbee521731caa40ae2fea6f29af68 (patch)
tree82c1978d0f7ab679f204bb94e496a22de9a28378 /CMakeLists.txt
parentd5bdad9b22c20c4d85b9a26f00e1ed8b137eb3f6 (diff)
downloadkxmleditor-25fe483e16bfbee521731caa40ae2fea6f29af68.tar.gz
kxmleditor-25fe483e16bfbee521731caa40ae2fea6f29af68.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54b1b40..6bb6546 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )