summaryrefslogtreecommitdiffstats
path: root/smb4k/dialogs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'smb4k/dialogs/Makefile.am')
-rw-r--r--smb4k/dialogs/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/smb4k/dialogs/Makefile.am b/smb4k/dialogs/Makefile.am
new file mode 100644
index 0000000..28a1b47
--- /dev/null
+++ b/smb4k/dialogs/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+lib_LTLIBRARIES = libsmb4kdialogs.la
+libsmb4kdialogs_la_LDFLAGS = -avoid-version -no-undefined $(all_libraries)
+libsmb4kdialogs_la_SOURCES = smb4kbookmarkeditor.cpp \
+ smb4kcustomoptionsdialog.cpp smb4kmountdialog.cpp smb4kpreviewdialog.cpp smb4kprintdialog.cpp \
+ smb4ksynchronizationdialog.cpp
+libsmb4kdialogs_la_LIBADD = $(top_builddir)/smb4k/core/libsmb4kcore.la \
+ $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_QT)
+noinst_HEADERS = smb4kbookmarkeditor.h smb4kmountdialog.h smb4kpreviewdialog.h \
+ smb4kprintdialog.h smb4ksynchronizationdialog.h