summaryrefslogtreecommitdiffstats
path: root/trinity-apps/knowit
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-29 14:23:41 +0200
committerChris <xchrisx@uber.space>2020-03-29 14:23:41 +0200
commitf07444e61bbe03ef9a3e8c2050cc2d66cf2ff2bb (patch)
tree7a2b932e99ffbe056672ee39c3424f697f9ec2a5 /trinity-apps/knowit
parent2bd9a5a4b5cd54d9b1446b275bc6b6baec05e426 (diff)
downloadtde-packaging-gentoo-f07444e61bbe03ef9a3e8c2050cc2d66cf2ff2bb.tar.gz
tde-packaging-gentoo-f07444e61bbe03ef9a3e8c2050cc2d66cf2ff2bb.zip
Live ebuilds: Add preliminary `KNowIt` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/knowit')
-rw-r--r--trinity-apps/knowit/knowit-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-apps/knowit/knowit-9999.ebuild b/trinity-apps/knowit/knowit-9999.ebuild
new file mode 100644
index 00000000..aed32b21
--- /dev/null
+++ b/trinity-apps/knowit/knowit-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es fr hu nl pl ru sk zh_CN"
+
+inherit trinity-base-2
+
+DESCRIPTION="Tool for managing notes"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}