summaryrefslogtreecommitdiffstats
path: root/trinity-apps/konversation
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-12-06 16:11:21 -0500
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-02-17 16:47:41 +0000
commitf0575f757d3a116ae806b578b37ae4b375a8caf5 (patch)
tree9055d8aa3000cc5d7a90675a7cc27d0d3d54acef /trinity-apps/konversation
parent32f776ede66c742cd2dceecb3739b083ac41d92b (diff)
downloadtde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.tar.gz
tde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.zip
14.0.8 ebuilds for everything in trinity-apps that I could make build back in June.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-apps/konversation')
-rw-r--r--trinity-apps/konversation/Manifest2
-rw-r--r--trinity-apps/konversation/konversation-14.0.8.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/konversation/Manifest b/trinity-apps/konversation/Manifest
new file mode 100644
index 00000000..4c84f4d1
--- /dev/null
+++ b/trinity-apps/konversation/Manifest
@@ -0,0 +1,2 @@
+DIST konversation-trinity-14.0.7.tar.xz 4421836 BLAKE2B 035a3bd237f529fbac09d1e905d7effd90227945084a820101a12ed2abf0d0f89dd4a2e2ea589e2bbcfe4d713c10af6eafbd71413d2395880f8b7a1a1be93cdf SHA512 809c9a18124c499274caf5feddf6501349fae8d1630edd6d854e6acbe8d10f5f098f812cb3fe8abde39bd3e893db5903670a8ce97f41a05dc6a1ea7209866478
+DIST konversation-trinity-14.0.8.tar.xz 4420040 BLAKE2B c05358b0f4dd6ea24ac7779471e696e64f8ffcd772d3b7c1485bf26a236f0981cac8a224f9f7880b8ff9dff33c434656513268074d9b648c247d972a9e50806d SHA512 0ec6b813e5dd7bbb7134afc1aa02351defeade2c98c861e7f08b5a9675c5c5ed70eceb7426fd26e5cf4e4d0d445404f2ef18bd123bf4b4593b9cf520de1b43ae
diff --git a/trinity-apps/konversation/konversation-14.0.8.ebuild b/trinity-apps/konversation/konversation-14.0.8.ebuild
new file mode 100644
index 00000000..9bf18411
--- /dev/null
+++ b/trinity-apps/konversation/konversation-14.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg ca da de el en_GB es et fi fr gl he
+ hu it ja ka ko pa pt ru sr sr@Latn sv tr zh_CN zh_TW"
+
+TRINITY_DOC_LANGS="da es et it pt ru sv"
+
+inherit trinity-base-2
+
+DESCRIPTION="A user friendly IRC Client for Trinity"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" xscreensaver"
+
+DEPEND+=" xscreensaver? ( x11-libs/libXScrnSaver )"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ )
+
+ trinity-base-2_src_configure
+}