summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-16 17:33:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-01 19:44:24 +0100
commit9f8752238e53404f81d175d0f65e9d85b0192785 (patch)
tree7681d92ef3975e6b8130ed781160d985b66d35e4 /trinity-apps
parenta9883953dbb16bcfeab49cbc2267e0f2d6959474 (diff)
downloadtde-packaging-gentoo-9f8752238e53404f81d175d0f65e9d85b0192785.tar.gz
tde-packaging-gentoo-9f8752238e53404f81d175d0f65e9d85b0192785.zip
trinity-apps/amarok: Drop IUSE=riokarma, missing media-libs/libkarma
media-libs/libkarma was dropped from Gentoo ebuild repo in 2016 and requires mono. With media-libs/libkarma neither in this repository nor in Gentoo ebuild repo we can not depend on it here. Sort dependencies. Package-Manager: Portage-3.0.9, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/amarok/amarok-9999.ebuild33
-rw-r--r--trinity-apps/amarok/metadata.xml1
2 files changed, 16 insertions, 18 deletions
diff --git a/trinity-apps/amarok/amarok-9999.ebuild b/trinity-apps/amarok/amarok-9999.ebuild
index de326228..86a807b2 100644
--- a/trinity-apps/amarok/amarok-9999.ebuild
+++ b/trinity-apps/amarok/amarok-9999.ebuild
@@ -31,7 +31,7 @@ SLOT="${TRINITY_VER}"
# The only ones supported at the moment are Xine and Akode.
# Yauap isn't in Portage tree, but could be added later.
#
-# - Rio Karma support needs libkarma which neeeds to be added to our overlay later.
+# - Rio Karma support needs nonexistent media-libs/libkarma
#
# - No Support for DAAP because it's not tested if that works with Mongrel2.
#
@@ -40,7 +40,7 @@ SLOT="${TRINITY_VER}"
# - Otherwise the ebuild should offer all what can be done with CMake at the moment.
IUSE="akode amazon ifp inotify ipod konqsidebar mp4 mtp mysql njb
-opengl postgres riokarma visualization +xine"
+opengl postgres visualization +xine"
REQUIRED_USE="|| ( xine akode )"
@@ -57,7 +57,6 @@ DEPEND+="
njb? ( media-libs/libnjb )
opengl? ( virtual/opengl )
postgres? ( dev-db/postgresql )
- riokarma? ( media-libs/libkarma )
visualization? (
media-libs/libsdl
media-plugins/libvisual-plugins
@@ -67,25 +66,25 @@ DEPEND+="
RDEPEND+=" ${DEPEND}"
src_configure() {
- mycmakeargs=(
- -DWITH_AMAZON="$(usex amazon)"
- -DWITH_KONQSIDEBAR="$(usex konqsidebar)"
- -DWITH_XINE="$(usex xine)"
+ local mycmakeargs=(
+ -DWITH_SYSTEM_SQLITE=ON
+ -DWITH_DAAP=OFF
+ -DWITH_RIOKARMA=OFF
+ -DWITH_YAUAP=OFF
-DWITH_AKODE="$(usex akode)"
- -DWITH_IPOD="$(usex ipod)"
- -DWITH_RIOKARMA="$(usex riokarma)"
+ -DWITH_AMAZON="$(usex amazon)"
-DWITH_IFP="$(usex ifp)"
- -DWITH_NJB="$(usex njb)"
- -DWITH_MTP="$(usex mtp)"
- -DWITH_MP4V2="$(usex mp4)"
-DWITH_INOTIFY="$(usex inotify)"
- -DWITH_OPENGL="$(usex opengl)"
- -DWITH_LIBVISUAL="$(usex visualization)"
+ -DWITH_IPOD="$(usex ipod)"
+ -DWITH_KONQSIDEBAR="$(usex konqsidebar)"
+ -DWITH_MP4V2="$(usex mp4)"
+ -DWITH_MTP="$(usex mtp)"
-DWITH_MYSQL="$(usex mysql)"
+ -DWITH_NJB="$(usex njb)"
+ -DWITH_OPENGL="$(usex opengl)"
-DWITH_POSTGRESQL="$(usex postgres)"
- -DWITH_SYSTEM_SQLITE=ON
- -DWITH_YAUAP=OFF
- -DWITH_DAAP=OFF
+ -DWITH_LIBVISUAL="$(usex visualization)"
+ -DWITH_XINE="$(usex xine)"
)
trinity-base-2_src_configure
diff --git a/trinity-apps/amarok/metadata.xml b/trinity-apps/amarok/metadata.xml
index 8a8e0c4d..6910d56a 100644
--- a/trinity-apps/amarok/metadata.xml
+++ b/trinity-apps/amarok/metadata.xml
@@ -8,7 +8,6 @@
<flag name="ifp">Enable support for iRiver devices access through <pkg>media-libs/libifp</pkg></flag>
<flag name="konqsidebar">Enable konqueror sidebar plugin</flag>
<flag name="njb">Enable support for NJB (Creative) devices access through <pkg>media-libs/libnjb</pkg></flag>
- <flag name="riokarma">Enable support for Rio Karma devices via <pkg>media-libs/libkarma</pkg></flag>
<flag name="visualization">Support visualization plugins through <pkg>media-libs/libvisual</pkg></flag>
</use>
</pkgmetadata>