summaryrefslogtreecommitdiffstats
path: root/trinity-base/arts
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-base/arts
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/arts')
-rw-r--r--trinity-base/arts/Manifest1
-rw-r--r--trinity-base/arts/arts-14.0.13.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/trinity-base/arts/Manifest b/trinity-base/arts/Manifest
index 427133c3..c9f7a844 100644
--- a/trinity-base/arts/Manifest
+++ b/trinity-base/arts/Manifest
@@ -1 +1,2 @@
DIST arts-trinity-14.0.12.tar.xz 662604 BLAKE2B 7c1661b1ecae8e5549757030258b8bb8d8eef27146980e50c59de2a762a582dba3e0a5381fbe209ac6f39370b66bf3fa3fe4a267307074bd99a2b70fccbd7458 SHA512 b0a99bae04c45ad6fd8ceb80280cfdcb2a3d4e20073d33658a38bd9a6dd62d98f67783abb784260d7179dfad2861587de5fc170648950f8033d9c68eb3b7bc95
+DIST arts-trinity-14.0.13.tar.xz 663772 BLAKE2B 63ae994c8757a764ff430885d1bdf0d998537b6bf40f5c86b21a4de3f6069059f494d015499d9dab5296db9181a1d0aeb1173a375573c7250a5b7ea59386d4cc SHA512 82c1b8a62ed4546eb00ff795e28a0b51eb395fe53a1e2ae93e1ff8bd23caa8f53dce776accfcef5ced3d4fbb8264cea7acc947ecb183236c0bbe4e5e59eeca5c
diff --git a/trinity-base/arts/arts-14.0.13.ebuild b/trinity-base/arts/arts-14.0.13.ebuild
new file mode 100644
index 00000000..1c9e2dc7
--- /dev/null
+++ b/trinity-base/arts/arts-14.0.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="arts"
+inherit trinity-base-2
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+IUSE="alsa -artswrappersuid jack mp3 vorbis"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+SLOT="14"
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+ dev-libs/glib
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( virtual/jack )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIOFILE=ON
+ -DWITH_MAD="$(usex mp3)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_VORBIS="$(usex vorbis)"
+ -DWITH_JACK="$(usex jack)"
+ -DWITH_ESOUND=OFF
+ -DWITH_SNDIO=OFF
+ )
+
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ trinity-base-2_src_install
+
+ # Used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${TDEDIR}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${TDEDIR}/bin/artswrapper to let artsd use realtime"
+ elog "priority and so avoid possible skips in sound. However, on untrusted systems"
+ elog "this creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See Gentoo bug #7883."
+ elog "Or, you can set the artswrappersuid USE flag to make the ebuild do this."
+ fi
+}