summaryrefslogtreecommitdiffstats
path: root/trinity-base/arts
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/arts
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/arts')
-rw-r--r--trinity-base/arts/Manifest1
-rw-r--r--trinity-base/arts/arts-14.0.11.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/trinity-base/arts/Manifest b/trinity-base/arts/Manifest
index 17019aaa..835d4443 100644
--- a/trinity-base/arts/Manifest
+++ b/trinity-base/arts/Manifest
@@ -1 +1,2 @@
+DIST arts-trinity-14.0.11.tar.xz 661156 BLAKE2B a288d34c984be3bdaaee0681de1593b470e067fedc2e8930b009857b6951e9887c8c21fe99e91f03092748a2188dcec1b6305616544e9f9c692b5cb91a3fc9c9 SHA512 e98229967416f5e5bc5b1e70460cd02bc9c2ecef0908e8e4af77a1f160b4845e63c6fb3cfb5ac5613e92f6e52329ac8db4649cd90260d1204ade7a0d07a5e30d
DIST arts-trinity-14.0.8.tar.xz 681888 BLAKE2B 986bed9f7450d39a26629077f9f966e2f34861539893250773e85d85c394e7ee2312a00066b5dacc653195d5b22f996fdc44ffddc188517e5a54d7cd15fce467 SHA512 e42d06787cb8e5c409b82db3470659a9d8066896a5116a5148d0ee30921a5bc4ce50155cdf5bac90f6afd3857038f8a5a3fe131b1d3e043a258859a24c183753
diff --git a/trinity-base/arts/arts-14.0.11.ebuild b/trinity-base/arts/arts-14.0.11.ebuild
new file mode 100644
index 00000000..f59262c3
--- /dev/null
+++ b/trinity-base/arts/arts-14.0.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="arts"
+inherit trinity-base-2
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+IUSE="alsa -artswrappersuid jack mp3 vorbis"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+SLOT="14"
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+ dev-libs/glib
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( virtual/jack )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIOFILE=ON
+ -DWITH_MAD="$(usex mp3)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_VORBIS="$(usex vorbis)"
+ -DWITH_JACK="$(usex jack)"
+ -DWITH_ESOUND=OFF
+ -DWITH_SNDIO=OFF
+ )
+
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ trinity-base-2_src_install
+
+ # Used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${TDEDIR}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${TDEDIR}/bin/artswrapper to let artsd use realtime"
+ elog "priority and so avoid possible skips in sound. However, on untrusted systems"
+ elog "this creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See Gentoo bug #7883."
+ elog "Or, you can set the artswrappersuid USE flag to make the ebuild do this."
+ fi
+}