summaryrefslogtreecommitdiffstats
path: root/trinity-base/arts
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-18 19:10:36 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 23:18:46 +0000
commitcc1ac24d4da2167f8d35239f7b9ecb3096adcba1 (patch)
treeae2ec4bbadf8bbabc55bb120e6f8b81f0a3a4c89 /trinity-base/arts
parent59a5a64b42421e246b5b90bf0d944299346faa7e (diff)
downloadtde-packaging-gentoo-cc1ac24d4da2167f8d35239f7b9ecb3096adcba1.tar.gz
tde-packaging-gentoo-cc1ac24d4da2167f8d35239f7b9ecb3096adcba1.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 7.
This time: filelight, kdcop, kdf, kmix, knutclient, konversation, ksensors, noatun-plugins, tdegames-doc, tdeinit, tdepowersave, tde-i18n, arts, libtdenetwork, atlantik, kasteroids, katomic, kbackgammon, kbattleship, kblackbox, kbounce, kenolaba, kfouleggs, kgoldrunner, kjumpingcube, klickety, klines, kmahjongg, kmines, knetwalk, kolf, konquest, kpat, kpoker, kreversi, ksame, kshisen, ksirtet, ksmiletris, ksnake, ksokoban, kspaceduel, ktron, ktuberling, libtdegames, lskat, twin4, akregator, kaddressbook, kgantt, kmobile, knode, knotes, kontact, korganizer, ktnef, libkcal, libkholidays, libkmime, libkpimexchange, libkpimidentities, libtdepim and mimelib Also: Move filelight to trinity-apps. Fix tdegames-meta to use trinity-base. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/arts')
-rw-r--r--trinity-base/arts/arts-9999.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/trinity-base/arts/arts-9999.ebuild b/trinity-base/arts/arts-9999.ebuild
index 4735503b..155b8bf3 100644
--- a/trinity-base/arts/arts-9999.ebuild
+++ b/trinity-base/arts/arts-9999.ebuild
@@ -1,49 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_TYPE="dependencies"
-TRINITY_MODULE_NAME="${PN}"
+TRINITY_MODULE_NAME="arts"
-inherit trinity-base
+inherit trinity-base-2
set-trinityver
DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
-LICENSE="GPL-2"
-KEYWORDS=
IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
SLOT="$TRINITY_VER"
-DEPEND="dev-tqt/tqtinterface
- dev-libs/glib:2
+DEPEND="=dev-tqt/tqtinterface-${PV}
+ dev-libs/glib
media-libs/audiofile
mp3? ( media-libs/libmad )
nas? ( media-libs/nas )
alsa? ( media-libs/alsa-lib )
vorbis? ( media-libs/libogg media-libs/libvorbis )
- jack? ( >=media-sound/jack-audio-connection-kit-0.90 )"
+ jack? ( media-sound/jack-audio-connection-kit )"
RDEPEND="${RDEPEND}"
src_configure() {
mycmakeargs=(
-DAUDIOFILE=ON
- $(cmake-utils_use_with mp3 MAD)
- $(cmake-utils_use_with nas NAS)
- $(cmake-utils_use_with alsa ALSA)
- $(cmake-utils_use_with vorbis VORBIS)
- $(cmake-utils_use_with jack JACK)
+ -DWITH_MAD="$(usex mp3)"
+ -DWITH_NAS="$(usex nas)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_VORBIS="$(usex vorbis)"
+ -DWITH_JACK="$(usex jack)"
# NOTE: WITH_ESD dropped due to remove of esound long ago
)
- trinity-base_src_configure
+ trinity-base-2_src_configure
}
src_install() {
- trinity-base_src_install
+ trinity-base-2_src_install
# used for realtime priority, but off by default as it is a security hazard
use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
@@ -54,7 +54,7 @@ pkg_postinst() {
elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
elog "and so avoid possible skips in sound. However, on untrusted systems this"
elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
- elog "priority, and so is off by default. See bug #7883."
+ elog "priority, and so is off by default. See Gentoo bug #7883."
elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
fi
}