summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcontrol
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-12-31 18:39:26 +0300
committerormorph <roma251078@mail.ru>2023-12-31 18:39:26 +0300
commit75781374864d2810908644e1ed2e5cd3835307d8 (patch)
tree6840ae0d3416e2ece90189a17a7b6d2b6a2f918c /trinity-base/kcontrol
parent01638c7e3c6fab0c1679bd5153ecb4764b9830c7 (diff)
downloadtde-packaging-gentoo-75781374864d2810908644e1ed2e5cd3835307d8.tar.gz
tde-packaging-gentoo-75781374864d2810908644e1ed2e5cd3835307d8.zip
Adding patches for compatibility with glibc-2.38
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kcontrol')
-rw-r--r--trinity-base/kcontrol/files/tdebase-strlcpy.patch29
-rw-r--r--trinity-base/kcontrol/kcontrol-14.1.1.ebuild5
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-base/kcontrol/files/tdebase-strlcpy.patch b/trinity-base/kcontrol/files/tdebase-strlcpy.patch
new file mode 100644
index 00000000..c117154d
--- /dev/null
+++ b/trinity-base/kcontrol/files/tdebase-strlcpy.patch
@@ -0,0 +1,29 @@
+--- a/ConfigureChecks.cmake 2023-11-13 20:24:40.136525876 +0300
++++ b/ConfigureChecks.cmake 2023-11-13 20:30:04.069534276 +0300
+@@ -23,6 +23,10 @@
+ find_package( TQt )
+ find_package( TDE )
+
++check_function_exists( strlcat HAVE_STRLCAT )
++check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++check_function_exists( strlcpy HAVE_STRLCPY )
++check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
+
+ ##### look for the usb.ids file, Its location can be set EG: -DWITH_USBIDS="/opt/share/misc/usb.ids"
+
+@@ -387,15 +391,6 @@
+ endif( )
+
+
+-# strlcat, strlcpy
+-if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
+- check_function_exists( strlcat HAVE_STRLCAT )
+- check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
+- check_function_exists( strlcpy HAVE_STRLCPY )
+- check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
+-endif( )
+-
+-
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/kcontrol/kcontrol-14.1.1.ebuild b/trinity-base/kcontrol/kcontrol-14.1.1.ebuild
index 520b7d2f..b5173fc2 100644
--- a/trinity-base/kcontrol/kcontrol-14.1.1.ebuild
+++ b/trinity-base/kcontrol/kcontrol-14.1.1.ebuild
@@ -37,6 +37,11 @@ RDEPEND="${DEPEND}
svg? ( media-libs/libart_lgpl )
"
+src_prepare() {
+ eapply "${FILESDIR}/tdebase-strlcpy.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_XCURSOR=ON