summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-9999.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-03 14:12:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 01:49:57 +0100
commit1ebc9f7807db09eb53d7f304c4d4126700c6b297 (patch)
tree42fd1e502522a40d2c2f002399515048b235405c /trinity-base/kdesktop/kdesktop-9999.ebuild
parent5732f27c0e26d2fba84055858043018f5b458718 (diff)
downloadtde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.tar.gz
tde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.zip
*/*: 9999: Sanitise eclass/ebuild vars, drop set-trinityver and need-trinity
Uniform ebuild variable blocks according to skel.ebuild and by devmanual example Sort some DEPENDs, fix some DESCRIPTIONs Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-9999.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/trinity-base/kdesktop/kdesktop-9999.ebuild b/trinity-base/kdesktop/kdesktop-9999.ebuild
index 9e1a156d..9bbb1927 100644
--- a/trinity-base/kdesktop/kdesktop-9999.ebuild
+++ b/trinity-base/kdesktop/kdesktop-9999.ebuild
@@ -3,18 +3,20 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_NAME="tdebase"
+TSM_EXTRACT_ALSO="kcheckpass/ translations/"
inherit trinity-meta-2
DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
IUSE="pam xscreensaver"
-COMMON_DEPEND="x11-libs/libXrender
- x11-libs/libXcursor
+COMMON_DEPEND="
~dev-libs/dbus-1-tqt-${PV}
- ~trinity-base/libkonq-${PV}
~trinity-base/kcontrol-${PV}
+ ~trinity-base/libkonq-${PV}
+ x11-libs/libXrender
+ x11-libs/libXcursor
xscreensaver? ( x11-libs/libXScrnSaver )"
# Requires the desktop background settings module,
# so until we separate the kcontrol modules into separate ebuilds :-),
@@ -27,16 +29,13 @@ RDEPEND="${COMMON_DEPEND}
~trinity-base/konqueror-${PV}
pam? ( trinity-base/tdebase-pam )"
-TSM_EXTRACT_ALSO="kcheckpass/ translations/"
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_XCURSOR=ON
-DWITH_XRENDER=ON
-DWITH_PAM="$(usex pam)"
-DWITH_XSCREENSAVER="$(usex xscreensaver)"
-DTDESCREENSAVER_PAM_SERVICE=tde
)
-
trinity-meta-2_src_configure
}