summaryrefslogtreecommitdiffstats
path: root/trinity-base/kxkb
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-05-02 16:35:47 -0400
committerE. Liddell <ejlddll@warpmail.net>2020-05-02 16:35:47 -0400
commitcb75382958ee83980cc8643be9a8c835b5ce615d (patch)
tree66bd2e70345a89a24cb872ad25c080fd8fd6abc3 /trinity-base/kxkb
parentffde2042a0595a8bd6e421c94ed74284eba05c82 (diff)
downloadtde-packaging-gentoo-cb75382958ee83980cc8643be9a8c835b5ce615d.tar.gz
tde-packaging-gentoo-cb75382958ee83980cc8643be9a8c835b5ce615d.zip
14.0.7 ebuilds for tdebase, tdeartwork, and dependencies (auto-generated)
Diffstat (limited to 'trinity-base/kxkb')
-rw-r--r--trinity-base/kxkb/kxkb-14.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/kxkb/kxkb-14.0.7.ebuild b/trinity-base/kxkb/kxkb-14.0.7.ebuild
new file mode 100644
index 00000000..f239dceb
--- /dev/null
+++ b/trinity-base/kxkb/kxkb-14.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+DESCRIPTION="KControl module to configure and switch keyboard layouts"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXtst"
+RDEPEND="${DEPEND}
+ x11-misc/xkeyboard-config
+ x11-apps/setxkbmap"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XTEST=ON
+ )
+
+ trinity-meta-2_src_configure
+}