summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdetoys-doc
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 14:42:15 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-28 19:14:41 +0100
commit67151d41efefb81a0ae15d576e49847205b63c83 (patch)
tree92e672ade8043e9ebf25d625dce868758df963d9 /trinity-base/tdetoys-doc
parent580c04e71b02ea271fece12df57c081a87243c9e (diff)
downloadtde-packaging-gentoo-67151d41efefb81a0ae15d576e49847205b63c83.tar.gz
tde-packaging-gentoo-67151d41efefb81a0ae15d576e49847205b63c83.zip
14.0.7 and 14.0.8 ebuilds for tdetoys
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/tdetoys-doc')
-rw-r--r--trinity-base/tdetoys-doc/Manifest2
-rw-r--r--trinity-base/tdetoys-doc/tdetoys-doc-14.0.7.ebuild27
-rw-r--r--trinity-base/tdetoys-doc/tdetoys-doc-14.0.8.ebuild27
3 files changed, 56 insertions, 0 deletions
diff --git a/trinity-base/tdetoys-doc/Manifest b/trinity-base/tdetoys-doc/Manifest
new file mode 100644
index 00000000..2c7d47cb
--- /dev/null
+++ b/trinity-base/tdetoys-doc/Manifest
@@ -0,0 +1,2 @@
+DIST tdetoys-trinity-14.0.7.tar.xz 2502528 BLAKE2B 307bda3318feff2695d4629480e4c00245d17fa95f58c282b6201d6d4383e57773d8d60138105ece1ed72ef0bde3623c47b013b6dfa7c676f38567fa04974a86 SHA512 3fc6f011a6aa714f9498a8d8fb04b10f8c1114b4741586d7b7258eb30f7a72e70eb8ff849b4aa7a846ad98a5b330d24664a198ccc8f77b61e39d53cb97aed699
+DIST tdetoys-trinity-14.0.8.tar.xz 2504340 BLAKE2B 32bdb687d5c9339a692a6a610263ba2a9200dc50d24461a8b23dc8662270b5491895bd64f434405cca95d5e10343f63b347e222df0f9e9d9ff47204ef04b996b SHA512 218ad0599c55580ab99d77f768429ff42f2aba3c839f49c3d73e245eb436afa88e103149a9306f80db79d7793d74471ce0233dc2fd4c1bc472bf3e807835bd82
diff --git a/trinity-base/tdetoys-doc/tdetoys-doc-14.0.7.ebuild b/trinity-base/tdetoys-doc/tdetoys-doc-14.0.7.ebuild
new file mode 100644
index 00000000..efd3ea07
--- /dev/null
+++ b/trinity-base/tdetoys-doc/tdetoys-doc-14.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdetoys"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdetoys-derived packages"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~trinity-base/khelpcenter-${PV}"
+
+pkg_setup() {
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
+ fi
+
+ trinity-meta-2_pkg_setup
+}
diff --git a/trinity-base/tdetoys-doc/tdetoys-doc-14.0.8.ebuild b/trinity-base/tdetoys-doc/tdetoys-doc-14.0.8.ebuild
new file mode 100644
index 00000000..efd3ea07
--- /dev/null
+++ b/trinity-base/tdetoys-doc/tdetoys-doc-14.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdetoys"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdetoys-derived packages"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~trinity-base/khelpcenter-${PV}"
+
+pkg_setup() {
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
+ fi
+
+ trinity-meta-2_pkg_setup
+}