summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kdiff3/kdiff3-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kdiff3/kdiff3-14.0.12.ebuild')
-rw-r--r--trinity-apps/kdiff3/kdiff3-14.0.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kdiff3/kdiff3-14.0.12.ebuild b/trinity-apps/kdiff3/kdiff3-14.0.12.ebuild
new file mode 100644
index 00000000..2fd56ebe
--- /dev/null
+++ b/trinity-apps/kdiff3/kdiff3-14.0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar az bg br ca cs cy da de el es et fr ga gl hi hu is it ja
+ ka lt nb nl pl pt pt_BR ro ru rw sk sr sr@Latn sv ta tg tr uk zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="A diff and merge program for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}