summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild')
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild
new file mode 100644
index 00000000..a4e4e371
--- /dev/null
+++ b/trinity-apps/koffice-i18n/koffice-i18n-14.0.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+
+inherit trinity-base-2
+
+DESCRIPTION="TDE internationalization package for Koffice [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+TRINITY_LANGS="bg ca cs cy da de el en_GB es et eu fa fi
+ fr ga gl hu it ja km lv ms nb nds ne nl pl pt pt_BR
+ ru sk sl sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="$DEPEND"
+
+run_phase() {
+ local lang dir phase;
+ phase=${1}
+ lang=${2}
+
+ dir="koffice-i18n-${lang}"
+ pushd "${S}/${dir}" || die "No such dir: ${dir}"
+ trinity-base-2_${phase}
+ popd
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do run_phase src_prepare
+ eapply_user
+}
+
+src_configure() {
+ trinity_l10n_for_each_locale_do run_phase src_configure
+}
+
+src_compile() {
+ trinity_l10n_for_each_locale_do run_phase src_compile
+}
+
+src_install() {
+ trinity_l10n_for_each_locale_do run_phase src_install
+}