summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kplayer/kplayer-14.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kplayer/kplayer-14.1.2.ebuild')
-rw-r--r--trinity-apps/kplayer/kplayer-14.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/trinity-apps/kplayer/kplayer-14.1.2.ebuild b/trinity-apps/kplayer/kplayer-14.1.2.ebuild
new file mode 100644
index 00000000..134ea61a
--- /dev/null
+++ b/trinity-apps/kplayer/kplayer-14.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="be br ca cs cy da de el en_GB es et fi
+ fr ga gl he hu it ja nb nl pa pl pt
+ pt_BR ru sr sr@Latn sv tr zh_CN"
+
+TRINITY_DOC_LANGS="da es it pt sv"
+
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="KPlayer is a TDE media player based on mplayer."
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="media-video/mplayer"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}