summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kscope/kscope-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kscope/kscope-14.0.12.ebuild')
-rw-r--r--trinity-apps/kscope/kscope-14.0.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/trinity-apps/kscope/kscope-14.0.12.ebuild b/trinity-apps/kscope/kscope-14.0.12.ebuild
new file mode 100644
index 00000000..f9a19f20
--- /dev/null
+++ b/trinity-apps/kscope/kscope-14.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="TDE front-end to Cscope"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-util/cscope
+ dev-util/ctags
+ ~trinity-base/kate-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}