summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kshutdown/kshutdown-14.0.12.ebuild')
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.0.12.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild b/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild
new file mode 100644
index 00000000..2b148f08
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}