summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kstreamripper
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kstreamripper')
-rw-r--r--trinity-apps/kstreamripper/Manifest1
-rw-r--r--trinity-apps/kstreamripper/kstreamripper-14.0.12.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/kstreamripper/Manifest b/trinity-apps/kstreamripper/Manifest
index 62263e6a..5322fa9c 100644
--- a/trinity-apps/kstreamripper/Manifest
+++ b/trinity-apps/kstreamripper/Manifest
@@ -1 +1,2 @@
DIST kstreamripper-trinity-14.0.11.tar.xz 29232 BLAKE2B 966d6422dc2b54428f5fdfa53c157ed25ce635760061eb1a437803e078b3687526636ed5ac0889d99f3f71f32cb9ff694001d8d027d532012e9bfbc08322f36c SHA512 5f4c60a7b317193bbf3a8407ed9504e7fbeba6ccbb876e2b84eda77596e8545dcbbfb674591fea50d32488e0cb2edc897bc2683f5b7700ac4d25cd6b07e6600e
+DIST kstreamripper-trinity-14.0.12.tar.xz 29152 BLAKE2B 320aed097674a6400404ea059639a4e0a01774a8c0e5bdf54ce6bc252a02e35585a3985cc687f7dfec51261feb72d301b07210bebc0ba2140e685bc58459ca6b SHA512 39ba2a17b4b326e7131671152b33ce9e8602ae40310a0de0eacf38b6ef81b1166cb76ae9fa66f64f304b62a62522838796587b72588ced71c136a07a805e5334
diff --git a/trinity-apps/kstreamripper/kstreamripper-14.0.12.ebuild b/trinity-apps/kstreamripper/kstreamripper-14.0.12.ebuild
new file mode 100644
index 00000000..93d858b7
--- /dev/null
+++ b/trinity-apps/kstreamripper/kstreamripper-14.0.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="TDE frontend for streamripper"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="media-sound/streamripper"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}