summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mplayerthumbs
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mplayerthumbs')
-rw-r--r--trinity-apps/mplayerthumbs/mplayerthumbs-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-apps/mplayerthumbs/mplayerthumbs-9999.ebuild b/trinity-apps/mplayerthumbs/mplayerthumbs-9999.ebuild
new file mode 100644
index 00000000..dfc91eef
--- /dev/null
+++ b/trinity-apps/mplayerthumbs/mplayerthumbs-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="MPlayer based thumbnail generator for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" +strips"
+
+RDEPEND+=" media-video/mplayer"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_STRIPS_SUPPORT="$(usex strips)"
+ )
+
+ trinity-base-2_src_configure
+}