summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild')
-rw-r--r--trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild b/trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild
new file mode 100644
index 00000000..ce414634
--- /dev/null
+++ b/trinity-apps/tdepowersave/tdepowersave-14.0.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2019-2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs da de el es fi fr hi hu it ja km lt
+ nb nl pa pl pt pt_BR ru sl_SI sv tr uk zh_CN zh_TW"
+
+TRINITY_DOC_LANGS="cs de fi hu nb"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A TDE frontend for power management"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}