summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn/tdesvn-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdesvn/tdesvn-14.0.12.ebuild')
-rw-r--r--trinity-apps/tdesvn/tdesvn-14.0.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/tdesvn/tdesvn-14.0.12.ebuild b/trinity-apps/tdesvn/tdesvn-14.0.12.ebuild
new file mode 100644
index 00000000..27d63ea5
--- /dev/null
+++ b/trinity-apps/tdesvn/tdesvn-14.0.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="Subversion client with tight TDE integration"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="test"
+
+RESTRICT+=" !test? ( test )"
+
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ trinity-base-2_src_configure
+}