summaryrefslogtreecommitdiffstats
path: root/trinity-base/arts
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/arts')
-rw-r--r--trinity-base/arts/Manifest1
-rw-r--r--trinity-base/arts/arts-14.0.12.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/trinity-base/arts/Manifest b/trinity-base/arts/Manifest
index 896b5c00..bc36553a 100644
--- a/trinity-base/arts/Manifest
+++ b/trinity-base/arts/Manifest
@@ -1 +1,2 @@
DIST arts-trinity-14.0.11.tar.xz 661156 BLAKE2B a288d34c984be3bdaaee0681de1593b470e067fedc2e8930b009857b6951e9887c8c21fe99e91f03092748a2188dcec1b6305616544e9f9c692b5cb91a3fc9c9 SHA512 e98229967416f5e5bc5b1e70460cd02bc9c2ecef0908e8e4af77a1f160b4845e63c6fb3cfb5ac5613e92f6e52329ac8db4649cd90260d1204ade7a0d07a5e30d
+DIST arts-trinity-14.0.12.tar.xz 662604 BLAKE2B 7c1661b1ecae8e5549757030258b8bb8d8eef27146980e50c59de2a762a582dba3e0a5381fbe209ac6f39370b66bf3fa3fe4a267307074bd99a2b70fccbd7458 SHA512 b0a99bae04c45ad6fd8ceb80280cfdcb2a3d4e20073d33658a38bd9a6dd62d98f67783abb784260d7179dfad2861587de5fc170648950f8033d9c68eb3b7bc95
diff --git a/trinity-base/arts/arts-14.0.12.ebuild b/trinity-base/arts/arts-14.0.12.ebuild
new file mode 100644
index 00000000..1c9e2dc7
--- /dev/null
+++ b/trinity-base/arts/arts-14.0.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="arts"
+inherit trinity-base-2
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+IUSE="alsa -artswrappersuid jack mp3 vorbis"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+SLOT="14"
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+ dev-libs/glib
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( virtual/jack )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIOFILE=ON
+ -DWITH_MAD="$(usex mp3)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DWITH_VORBIS="$(usex vorbis)"
+ -DWITH_JACK="$(usex jack)"
+ -DWITH_ESOUND=OFF
+ -DWITH_SNDIO=OFF
+ )
+
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ trinity-base-2_src_install
+
+ # Used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${TDEDIR}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${TDEDIR}/bin/artswrapper to let artsd use realtime"
+ elog "priority and so avoid possible skips in sound. However, on untrusted systems"
+ elog "this creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See Gentoo bug #7883."
+ elog "Or, you can set the artswrappersuid USE flag to make the ebuild do this."
+ fi
+}