summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild')
-rw-r--r--trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild b/trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild
new file mode 100644
index 00000000..16954cdb
--- /dev/null
+++ b/trinity-base/kcheckpass/kcheckpass-14.0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+IUSE="pam"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="pam? ( trinity-base/tdebase-pam )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_SHADOW=ON
+ -DWITH_PAM="$(usex pam)"
+ -DKCHECKPASS_PAM_SERVICE=tde
+ )
+
+ trinity-meta-2_src_configure
+}