summaryrefslogtreecommitdiffstats
path: root/trinity-base/khotkeys/khotkeys-14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/khotkeys/khotkeys-14.0.7.ebuild')
-rw-r--r--trinity-base/khotkeys/khotkeys-14.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/khotkeys/khotkeys-14.0.7.ebuild b/trinity-base/khotkeys/khotkeys-14.0.7.ebuild
new file mode 100644
index 00000000..d0183d29
--- /dev/null
+++ b/trinity-base/khotkeys/khotkeys-14.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+need-arts optional
+
+DESCRIPTION="Trinity hotkey daemon"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXtst"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XTEST=ON
+ )
+
+ trinity-meta-2_src_configure
+}