summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/kicker-14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kicker/kicker-14.0.7.ebuild')
-rw-r--r--trinity-base/kicker/kicker-14.0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/trinity-base/kicker/kicker-14.0.7.ebuild b/trinity-base/kicker/kicker-14.0.7.ebuild
new file mode 100644
index 00000000..4ed93945
--- /dev/null
+++ b/trinity-base/kicker/kicker-14.0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+KEYWORDS="~amd64 ~x86"
+IUSE="xcomposite"
+
+DEPEND="=trinity-base/libkonq-${PV}
+ =trinity-base/tdebase-data-${PV}
+ dev-libs/dbus-tqt
+ xcomposite? ( x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ =trinity-base/kmenuedit-${PV}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XFIXES="$(usex xcomposite)"
+ -DWITH_XRENDER="$(usex xcomposite)"
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+
+ trinity-meta-2_src_configure
+}