summaryrefslogtreecommitdiffstats
path: root/trinity-base/konsole/konsole-14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/konsole/konsole-14.0.7.ebuild')
-rw-r--r--trinity-base/konsole/konsole-14.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-base/konsole/konsole-14.0.7.ebuild b/trinity-base/konsole/konsole-14.0.7.ebuild
new file mode 100644
index 00000000..1eb7ce0e
--- /dev/null
+++ b/trinity-base/konsole/konsole-14.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+DESCRIPTION="X terminal for use with Trinity."
+KEYWORDS="~amd64 ~x86"
+
+IUSE="sudo"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXrender"
+
+RDEPEND="${DEPEND}
+ sudo? ( app-admin/sudo )
+ x11-apps/bdftopcf
+ =trinity-base/kcontrol-${PV}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XRENDER=ON
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
+ )
+
+ trinity-meta-2_src_configure
+}