summaryrefslogtreecommitdiffstats
path: root/trinity-base/ksplashml/ksplashml-14.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/ksplashml/ksplashml-14.0.7.ebuild')
-rw-r--r--trinity-base/ksplashml/ksplashml-14.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/ksplashml/ksplashml-14.0.7.ebuild b/trinity-base/ksplashml/ksplashml-14.0.7.ebuild
new file mode 100644
index 00000000..17f59bdd
--- /dev/null
+++ b/trinity-base/ksplashml/ksplashml-14.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity splashscreen framework (of Trinity itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="xinerama"
+
+DEPEND="xinerama? ( x11-base/xorg-proto )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XINERAMA="$(usex xinerama)"
+ )
+
+ trinity-meta-2_src_configure
+}