summaryrefslogtreecommitdiffstats
path: root/trinity-base/lisa/lisa-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/lisa/lisa-14.0.12.ebuild')
-rw-r--r--trinity-base/lisa/lisa-14.0.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/trinity-base/lisa/lisa-14.0.12.ebuild b/trinity-base/lisa/lisa-14.0.12.ebuild
new file mode 100644
index 00000000..b4083981
--- /dev/null
+++ b/trinity-base/lisa/lisa-14.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+TRINITY_SUBMODULE="lanbrowsing"
+
+TRINITY_MODULE_NAME="tdenetwork"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_install() {
+ trinity-meta-2_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/lisa" > "${T}/lisa"
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${FILESDIR}/lisa.conf" lisa
+ newconfd "${FILESDIR}/reslisa.conf" reslisa
+
+ echo '# Default lisa configfile' > "$D/etc/lisarc"
+ echo '# Default reslisa configfile' > "$D/etc/reslisarc"
+}